GlobalProtect not properly disconnecting

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Palo Alto Networks Approved
Palo Alto Networks Approved
Community Expert Verified
Community Expert Verified

GlobalProtect not properly disconnecting

L5 Sessionator

We have GlobalProtect configured as always-on and the option to disconnect with comment. Sometimes when a user disconnects the GP app shows as disconnected, but they are in fact still connected, they have an IP from the gateway and still route through the gateway. The only way the user can get disconnected is by connecting to a different GP portal or restarting the service. This does not happen every time but its enough to be noticed. We are running GP 6.0.5. 

 

Has anyone experienced anything similar/have any ideas?

1 accepted solution

Accepted Solutions

Community Team Member

Hi @Claw4609 ,

 

You might want to check to GP logs.

There's a known issue in 6.0.4 and 6.0.5 where disconnect failed with the following error:

 

04/25/23 15:14:02:560 ----Disable starts----
04/25/23 15:14:02:560 GlobalProtect disabling was blocked due to signature mismatch.
04/25/23 15:14:02:560 ProcessServerDisableAgent failed
04/25/23 15:14:02:560 Error processing receive data from client
04/25/23 15:14:02:560 close client socket

 

You might want to check the logs or confirm with support if you're hitting the same issue.  Last I heard is this should be fixed 6.1.2, 5.2.14, 6.0.6.

 

Kind regards,

-Kim.

LIVEcommunity team member, CISSP
Cheers,
Kiwi
Please help out other users and “Accept as Solution” if a post helps solve your problem !

Read more about how and why to accept solutions.

View solution in original post

3 REPLIES 3

Community Team Member

Hi @Claw4609 ,

 

You might want to check to GP logs.

There's a known issue in 6.0.4 and 6.0.5 where disconnect failed with the following error:

 

04/25/23 15:14:02:560 ----Disable starts----
04/25/23 15:14:02:560 GlobalProtect disabling was blocked due to signature mismatch.
04/25/23 15:14:02:560 ProcessServerDisableAgent failed
04/25/23 15:14:02:560 Error processing receive data from client
04/25/23 15:14:02:560 close client socket

 

You might want to check the logs or confirm with support if you're hitting the same issue.  Last I heard is this should be fixed 6.1.2, 5.2.14, 6.0.6.

 

Kind regards,

-Kim.

LIVEcommunity team member, CISSP
Cheers,
Kiwi
Please help out other users and “Accept as Solution” if a post helps solve your problem !

Read more about how and why to accept solutions.

We are in fact getting GlobalProtect disabling was blocked due to signature mismatch in the debug logs. I apologize, I thought I mentioned that in my original post, I did not. Thank you for the info though!

L0 Member

Bug ID GPC-17227.
The release notes indicate that the issue has been resolved in GP App 6.0.7.

  • 1 accepted solution
  • 3097 Views
  • 3 replies
  • 0 Likes
  • 101 Subscriptions
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!