NAT Issue

Announcements

ATTENTION Customers, All Partners and Employees: The Customer Support Portal (CSP) will be undergoing maintenance and unavailable on Saturday, November 7, 2020, from 11 am to 11 pm PST. Please read our blog for more information.

Reply
Highlighted
L4 Transporter

NAT Issue

Hi Friends,

I have 2 server hosted in lan zone and one public ip . i have configure the NAT for 1 server from outside from port 80 and its working fine. but i want access the other server from lan with public ip from port 80 but its not working showing application is undirected. please suggest.

test i.png

Regards

Satish


Accepted Solutions
Highlighted
L7 Applicator

For the internal nat rule you also need to add source nat to force the reply traffic back to the firewall.  Otherwise the routing is asymmetrical directly back from the server to the source instead of through the firewall.  This is known as U turn or hairpin nat.  See this configuration example.

How to Configure U-Turn NAT

Steve Puluka BSEET - IP Architect - DQE Communications (Metro Ethernet/ISP)
ACE PanOS 6; ACE PanOS 7; ASE 3.0; PSE 7.0 Foundations & Associate in Platform; Cyber Security; Data Center

View solution in original post


All Replies
Highlighted
L7 Applicator

For the internal nat rule you also need to add source nat to force the reply traffic back to the firewall.  Otherwise the routing is asymmetrical directly back from the server to the source instead of through the firewall.  This is known as U turn or hairpin nat.  See this configuration example.

How to Configure U-Turn NAT

Steve Puluka BSEET - IP Architect - DQE Communications (Metro Ethernet/ISP)
ACE PanOS 6; ACE PanOS 7; ASE 3.0; PSE 7.0 Foundations & Associate in Platform; Cyber Security; Data Center

View solution in original post

Highlighted
L4 Transporter

Hi Steven,

Let me check and get back to you. :smileyhappy:

Regards

Satish

Highlighted
L0 Member

Hello,

I am new to PA firewalls. Is the U-TURN NAT really working for you sicne I have not seen anyone stating that it works. As a matter of fact I saw this link which shows it does not work. No TAC in Palo Alto is able to help me yet or state that it works or does not work. Pretty frustrting.

DNS Doctoring feature does not work. 

https://knowledgebase.paloaltonetworks.com/KCSArticleDetail?id=kA10g000000ClfjCAC

 

But I tried the workaround along with 3 different TACs and it did not work. Really appreciate any feedback.

 

Adil.

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!