PPPoE disconnect randomly

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Announcements
Please sign in to see details of an important advisory in our Customer Advisories area.

PPPoE disconnect randomly

L1 Bithead

Hello PaloAlto users!

 

Recently I purchased a PaloAlto from ebay and I have installed it in my home. I have the WAN interface (ethernet1/1) as PPPoE with the information from my ISP (Digi Spain) . Everything is okay regarding the configuration (or so i think) with my ISP, i got my IP, can navigate perfectly etc. but in some cases i got disconnection in my entire LAN. 


After tshoot and look in the monitor, I see the next message in the system tab monitor:

 

"PPPoE session failed to connect for user:XXXXXXXXX@digi on interface:ethernet1/1. Reason: Peer not responding, LCP down"

 

Does any one know what's happening?

 

More info:
- The ISP gives me the IP through CG-NAT

- The ISP line comes directly from the ONT with the vlan tagged (VlanID 20) connected to switch-Port1 (Tagged vlan 20) and switch-Port2 (untagged vlan20) to PaloAlto Eth1.

 

Thank's you

Best regards.

5 REPLIES 5

Community Team Member

Hi @Jlsierra ,

 

I would start by checking if you see extra information in the pppoed logs:

 

> less mp-log pppoed.log

 

Similar issue: https://live.paloaltonetworks.com/t5/general-topics/pppoe-disconnection-frequently/td-p/419653

 

Kind regards,

-Kim.

LIVEcommunity team member, CISSP
Cheers,
Kiwi
Please help out other users and “Accept as Solution” if a post helps solve your problem !

Read more about how and why to accept solutions.

Hello @kiwi 

 

Thank's you for the help. Just saw that threat but I don't see the solution.

 

I see this in the log

 

2024-02-28 05:10:56.344 +0100 Not adding EOL tag to PPPoE PADI packet on interface: ethernet1/1
2024-02-28 05:10:56.849 +0100 Not adding EOL tag to PPPoE PADR packet on interface: ethernet1/1
2024-02-28 05:10:56.849 +0100 Error: pan_pppoe_fsm_run(pan_pppoe_fsm.c:1182): [0xffd00385e0/16][0] Cannot process PPPoE pkt. Received PADO in non initiating state (2)
2024-02-28 05:10:56.849 +0100 Error: pan_pppoe_fsm_run(pan_pppoe_fsm.c:1183):
2024-02-28 05:10:56.849 +0100 Error: pan_pppoe_fsm_run(pan_pppoe_fsm.c:1182): [0xffd00385e0/16][0] Cannot process PPPoE pkt. Received PADO in non initiating state (2)
2024-02-28 05:10:56.849 +0100 Error: pan_pppoe_fsm_run(pan_pppoe_fsm.c:1183):
2024-02-28 05:10:57.349 +0100 Error: pan_pppoe_fsm_run(pan_pppoe_fsm.c:1182): [0xffd00385e0/16][0] Cannot process PPPoE pkt. Received PADO in non initiating state (3)
2024-02-28 05:10:57.349 +0100 Error: pan_pppoe_fsm_run(pan_pppoe_fsm.c:1183):
2024-02-28 05:10:57.351 +0100 Error: pan_pppoe_fsm_run(pan_pppoe_fsm.c:1182): [0xffd00385e0/16][0] Cannot process PPPoE pkt. Received PADO in non initiating state (3)
2024-02-28 05:10:57.352 +0100 Error: pan_pppoe_fsm_run(pan_pppoe_fsm.c:1183):
2024-02-28 05:10:57.352 +0100 Error: pan_pppoe_fsm_run(pan_pppoe_fsm.c:1182): [0xffd00385e0/16][0] Cannot process PPPoE pkt. Received PADO in non initiating state (3)
2024-02-28 05:10:57.352 +0100 Error: pan_pppoe_fsm_run(pan_pppoe_fsm.c:1183):
2024-02-28 05:10:57.352 +0100 Error: pan_pppoe_fsm_run(pan_pppoe_fsm.c:1182): [0xffd00385e0/16][0] Cannot process PPPoE pkt. Received PADO in non initiating state (3)
2024-02-28 05:10:57.352 +0100 Error: pan_pppoe_fsm_run(pan_pppoe_fsm.c:1183):
2024-02-28 05:10:57.352 +0100 Error: pan_pppoe_fsm_run(pan_pppoe_fsm.c:1182): [0xffd00385e0/16][0] Cannot process PPPoE pkt. Received PADO in non initiating state (3)
2024-02-28 05:10:57.352 +0100 Error: pan_pppoe_fsm_run(pan_pppoe_fsm.c:1183):
2024-02-28 05:10:59.959 +0100 Error: pan_ppp_fsm_run(pan_ppp_fsm.c:592): [0xffd00385e0/16][0] Unsupported protocol: 'IPv6 Control Protovol' (0x8057) received
2024-02-28 05:11:02.961 +0100 Error: pan_ppp_fsm_run(pan_ppp_fsm.c:592): [0xffd00385e0/16][0] Unsupported protocol: 'IPv6 Control Protovol' (0x8057) received
2024-02-28 05:11:05.963 +0100 Error: pan_ppp_fsm_run(pan_ppp_fsm.c:592): [0xffd00385e0/16][0] Unsupported protocol: 'IPv6 Control Protovol' (0x8057) received
2024-02-28 05:11:08.964 +0100 Error: pan_ppp_fsm_run(pan_ppp_fsm.c:592): [0xffd00385e0/16][0] Unsupported protocol: 'IPv6 Control Protovol' (0x8057) received
2024-02-28 05:11:11.964 +0100 Error: pan_ppp_fsm_run(pan_ppp_fsm.c:592): [0xffd00385e0/16][0] Unsupported protocol: 'IPv6 Control Protovol' (0x8057) received
2024-02-28 05:11:14.967 +0100 Error: pan_ppp_fsm_run(pan_ppp_fsm.c:592): [0xffd00385e0/16][0] Unsupported protocol: 'IPv6 Control Protovol' (0x8057) received
2024-02-28 05:11:17.969 +0100 Error: pan_ppp_fsm_run(pan_ppp_fsm.c:592): [0xffd00385e0/16][0] Unsupported protocol: 'IPv6 Control Protovol' (0x8057) received
2024-02-28 05:11:20.970 +0100 Error: pan_ppp_fsm_run(pan_ppp_fsm.c:592): [0xffd00385e0/16][0] Unsupported protocol: 'IPv6 Control Protovol' (0x8057) received
2024-02-28 05:11:23.971 +0100 Error: pan_ppp_fsm_run(pan_ppp_fsm.c:592): [0xffd00385e0/16][0] Unsupported protocol: 'IPv6 Control Protovol' (0x8057) received
2024-02-28 05:11:26.971 +0100 Error: pan_ppp_fsm_run(pan_ppp_fsm.c:592): [0xffd00385e0/16][0] Unsupported protocol: 'IPv6 Control Protovol' (0x8057) received
2024-02-28 19:15:31.494 +0100 Not adding EOL tag to PPPoE PADI packet on interface: ethernet1/1
2024-02-28 19:15:33.506 +0100 Not adding EOL tag to PPPoE PADR packet on interface: ethernet1/1
2024-02-28 19:15:34.004 +0100 Error: pan_pppoe_fsm_run(pan_pppoe_fsm.c:1182): [0xffd00385e0/16][0] Cannot process PPPoE pkt. Received PADO in non initiating state (3)
2024-02-28 19:15:34.004 +0100 Error: pan_pppoe_fsm_run(pan_pppoe_fsm.c:1183):
2024-02-28 19:15:34.004 +0100 Error: pan_pppoe_fsm_run(pan_pppoe_fsm.c:1182): [0xffd00385e0/16][0] Cannot process PPPoE pkt. Received PADO in non initiating state (3)
2024-02-28 19:15:34.004 +0100 Error: pan_pppoe_fsm_run(pan_pppoe_fsm.c:1183):
2024-02-28 19:15:34.005 +0100 Error: pan_pppoe_fsm_run(pan_pppoe_fsm.c:1182): [0xffd00385e0/16][0] Cannot process PPPoE pkt. Received PADO in non initiating state (3)
2024-02-28 19:15:34.005 +0100 Error: pan_pppoe_fsm_run(pan_pppoe_fsm.c:1183):
2024-02-28 19:15:34.005 +0100 Error: pan_pppoe_fsm_run(pan_pppoe_fsm.c:1182): [0xffd00385e0/16][0] Cannot process PPPoE pkt. Received PADO in non initiating state (3)
2024-02-28 19:15:34.005 +0100 Error: pan_pppoe_fsm_run(pan_pppoe_fsm.c:1183):
2024-02-28 19:15:34.010 +0100 Error: pan_pppoe_fsm_run(pan_pppoe_fsm.c:1182): [0xffd00385e0/16][0] Cannot process PPPoE pkt. Received PADO in non initiating state (3)
2024-02-28 19:15:34.010 +0100 Error: pan_pppoe_fsm_run(pan_pppoe_fsm.c:1183):
2024-02-28 19:15:34.012 +0100 Error: pan_pppoe_fsm_run(pan_pppoe_fsm.c:1182): [0xffd00385e0/16][0] Cannot process PPPoE pkt. Received PADO in non initiating state (3)
2024-02-28 19:15:34.012 +0100 Error: pan_pppoe_fsm_run(pan_pppoe_fsm.c:1183):
2024-02-28 19:15:35.010 +0100 Error: pan_pppoe_fsm_run(pan_pppoe_fsm.c:1182): [0xffd00385e0/16][0] Cannot process PPPoE pkt. Received PADO in non initiating state (3)
2024-02-28 19:15:35.010 +0100 Error: pan_pppoe_fsm_run(pan_pppoe_fsm.c:1183):
2024-02-28 19:15:36.949 +0100 Error: pan_ppp_fsm_run(pan_ppp_fsm.c:592): [0xffd00385e0/16][0] Unsupported protocol: 'IPv6 Control Protovol' (0x8057) received
2024-02-28 19:15:39.949 +0100 Error: pan_ppp_fsm_run(pan_ppp_fsm.c:592): [0xffd00385e0/16][0] Unsupported protocol: 'IPv6 Control Protovol' (0x8057) received
2024-02-28 19:15:42.951 +0100 Error: pan_ppp_fsm_run(pan_ppp_fsm.c:592): [0xffd00385e0/16][0] Unsupported protocol: 'IPv6 Control Protovol' (0x8057) received
2024-02-28 19:15:45.953 +0100 Error: pan_ppp_fsm_run(pan_ppp_fsm.c:592): [0xffd00385e0/16][0] Unsupported protocol: 'IPv6 Control Protovol' (0x8057) received
2024-02-28 19:15:48.955 +0100 Error: pan_ppp_fsm_run(pan_ppp_fsm.c:592): [0xffd00385e0/16][0] Unsupported protocol: 'IPv6 Control Protovol' (0x8057) received
2024-02-28 19:15:51.956 +0100 Error: pan_ppp_fsm_run(pan_ppp_fsm.c:592): [0xffd00385e0/16][0] Unsupported protocol: 'IPv6 Control Protovol' (0x8057) received
2024-02-28 19:15:54.956 +0100 Error: pan_ppp_fsm_run(pan_ppp_fsm.c:592): [0xffd00385e0/16][0] Unsupported protocol: 'IPv6 Control Protovol' (0x8057) received
2024-02-28 19:15:57.959 +0100 Error: pan_ppp_fsm_run(pan_ppp_fsm.c:592): [0xffd00385e0/16][0] Unsupported protocol: 'IPv6 Control Protovol' (0x8057) received
2024-02-28 19:16:00.962 +0100 Error: pan_ppp_fsm_run(pan_ppp_fsm.c:592): [0xffd00385e0/16][0] Unsupported protocol: 'IPv6 Control Protovol' (0x8057) received
2024-02-28 19:16:03.963 +0100 Error: pan_ppp_fsm_run(pan_ppp_fsm.c:592): [0xffd00385e0/16][0] Unsupported protocol: 'IPv6 Control Protovol' (0x8057) received

 

Yesterday I tried using the command "set system setting pppoe-dont-send-eol enable yes interface ethernet1/1" but still failing.

 

I had before a Mikrotik and had no issue about this. My PaloAlto software version is 10.1.11-h5

 

Thank you for the help ❤️

Best regards.

Community Team Member

Hi @Jlsierra ,

 

Based on the logs your ISP is offering you an IPv6 configuration on your PPPoE interface.

On PAN-OS 10.1.11 this isn't supported. 

 

This feature was introduced in PAN-OS 11.1.0:

https://docs.paloaltonetworks.com/pan-os/11-1/pan-os-release-notes/features-introduced-in-pan-os/net...

 

The firewall supports an Ethernet Layer 3 interface or subinterface acting as a Point-to-Point Protocol over Ethernet (PPPoE) IPv6 client to reach an ISP that provides IPv6 internet services.

 

Hope this helps,

-Kim.

LIVEcommunity team member, CISSP
Cheers,
Kiwi
Please help out other users and “Accept as Solution” if a post helps solve your problem !

Read more about how and why to accept solutions.

Thanks @kiwi for the help,

 

There's a big problem, as i mentioned, I have purchased this Pa820 in Ebay as refurbished and without license. I upgraded it to 10.1.11 but can't upgrade to 11.x because I need a major version of content updated. Tried to update with a package content update from the customer support portal but when I try to install in the device, this says thats no licensed ... =(

@kiwi Updated to 11.0.2-h2. My PaloAlto was 11.1.X but had to downgrade coz the management interface was so slow.

 

Now I have configured my port as subinterface with the right vlan and tag and still getting the same error. 

Jlsierra_0-1710175357965.png

=(

 

Thank you,

Best regards.

  • 615 Views
  • 5 replies
  • 0 Likes
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!