Unable to access Windows Store (Windows 10 + GP 3.0.2)

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to access Windows Store (Windows 10 + GP 3.0.2)

L7 Applicator



Does anyone else also have problems to access the windows store when connected with global protect vpn?

Actually the problem really only is the windows store app. Everything else works perfectly (internet access, accessing corporate ressources, internal websites, fileshares, ...). The store app only displays that I should check my internet connection and the error code 0x80072EFD.

The firewall has 7.0.6 installed and we have configured the vpn with the default route into the vpn tunnel.






My customer is really unhappy....can't we boost this issue?

Additionnlly customer has just migrated to GP 4.0.2...

We've opened a ticket to support, and are awaiting answer....




This is more of a Microsoft issue than it is strictly related to GlobalProtect. 

Palo Alto Networks Guru

So what is the issue ? We have customers successfully using the Windows 10 app. Are you referring to the app on Windows Store , https://www.microsoft.com/en-us/store/p/globalprotect/9nblggh6bzl3  or the regular GlobalProtect MSI app for Windows 10 that you download from our support portal or your GlobalProtect Portal.  If you want to know the difference between store app and regular app refer to https://www.paloaltonetworks.com/documentation/71/pan-os/newfeaturesguide/globalprotect-features/glo...


The best way to resolve an issue if you are not able to find an answer in the community is to open a support case.


The problem is NOT the Global Protect app/application. We also use the application and it works great. The only issue in this topic is: Accessing the windows store while connected to a global protect gateway with routed into the tunnel.

Now how are you going to solve an issue (if its not mission critical like this one) when:

  • PaloAlto says that it is a problem of windows
  • Microsoft does not care because the store is accessible without GP or with their own VPN, so it can't be a problem of windows

Palo Alto Networks Guru

Got it. Thanks for the clarification. Will invsetigate internally so as to what's happening and update the thread.


Another quick question, is this problem only when you are using the Wndows 10 UWP GlobalProtect app ? Meaning if you use the regualr windows GlobalProtect app on a windows 10 device and have the VPN established are you able to access the Windows Store ?

Hi @jmenon


We only use the Global Protect App (not UWP) from the support portal website. So I cannot say anything about the UWP App.

And in addition: The title of this topic is already a little wrong ... with 3.1.x and 4.0.0 it is also not possible to connect to the windows store.




Palo Alto Networks Guru

Got it. Investigating ... Will respond with what we find by next week,.

Palo Alto Networks Guru

so we tried internally and found it be working , i suggest you open a tac case so that we can investigate what's happening in your environment 



@jmenon wrote:

Got it. Investigating ... Will respond with what we find by next week,.


Ok?!? I mean cool, it works, but now I really wonder what we did wrong ... windows 8.1 / 10 with GP 3.0.x / 3.1.x / 4.0.x --> no success


You simply installed GP, connected and it worked right? Without doing any special trick?

Hello Joby,


Please, can you confirm that you can access Windows Store through GP ? 

Because, we didn'e manage to make it working.


thanks for your help


i also have the same issue. Normal desktop client application with going down the vpn. When connected to GP the MS Store says its not connected.


Anyone get this fixed?


Can you get to the store page and simply can't download or with the Store app simply not load, are you decrypting GP traffic, have you verified that the traffic is allowed? 

Haven't had any issues with using GP with the Windows Store however I have moved everyone up to the 4.1.1 client (very stable, haven't had any issues since we deployed it a while back; and IMHO is a much better client then the old versions). 

The windows store application states that there is no network connection. I am sending all traffic to Gp, no split tunnel.

Traffic is not being blocked, there is only one allow any any rule in place

L7 Applicator


How did you manage to get the windows store working when connected with global protect? When GP isn't connected there is no issue with the store but as soon you wan't to open the store with an established connection it won't show anything (GP 3.0, 3.1, 4.0, 4.1)


I'll take a look at it later today and see if I made any changes to anything and how the policys are actually configured, but I don't recall it ever really being an issue for me past early GP 3.0 days. 

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!