Showing results for 
Show  only  | Search instead for 
Did you mean: 

Who Me Too'd this topic

Interface re-mapping to ae subinterfaces

L4 Transporter

Hi Expedition team

Recently I had a project, which required changing a number of physical firewall interfaces to a single aggregated tagged sub-interfaces ( e.g. ethernet1/1,1/2, 1/3, etc. changed to ae1.1, 1.2, 1.3).

I decided to use Expedition “interface re-mapping” option. To start with I don’t seem to be able to directly rename Ethernet interface to ae sub interface. I found a workaround by first remapping Ethernet interface to ae (e.g. ethernet 1/11 to ae1), then I get duplicate ae1 interface and I edit the new ae1 interface, changing it from ae1 to ae1.11.

This worked, although it takes longer, because it needs two actions for each interface: remap erhernet1/11 to ae1, then rename ae1 to ae1.11.

The other problem was that not all references to the Ethernet interfaces were changes. For example in Interfaces references were not changed in the following places:

  • In NAT policies interface was changed in the translated source, however not changed in “Original Packet -> Destination Interface.
  • Interfaces in PBF policies were not changed
  • Interfaces not changed in Global Protect Portals and Gateways.
  • Local Interface in VPN Gateways were not changed
  • QoS Interfaces were not changed, however this is understandable.


I had to manually edit the XML file, which eventually worked, however it was a lot of additional work and prone to mistakes.

I really like the tool and find it an enormous help.

I am not sure if this is the right place to report bugs. I just wanted to check if this is the expected behaviour or if it is a bug that can be fixed. 

Who Me Too'd this topic