Best Practices Analysis Not Running

Showing results for 
Search instead for 
Did you mean: 

Best Practices Analysis Not Running

L1 Bithead

I'm trying to run a BPA for one of my Panorama-managed devices. I got everything imported into the project, but the BPA never runs. The progress bar advances to "Done!" with no visible errors on the front-end, but Last Run stays at Never Analyzed. Checking the Apache error logs, it appears thta there's a missing executable (bpa-cli). Is this something we have to get separately?


It's working now with update 1.0.92 and the python update.



Any news about the new repo ?


Still having the following ssue in 2018 :


expedition@Expedition:~$ sudo apt-get update
Reading package lists... Done
W: The repository ' expedition-updates/ Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.

L0 Member

I'm not seeing any results in the BPA. I've tried with a Panorama XML as well as a running config from a connected device. The progress bar goes to "Done!" and I don't get any results.


Expedition version 1.0.103

BPA version is not showing anything


I've run apt-get update and install and still no luck.

Do you remember if after any expedition update you followed this instructions?


sudo bash /var/www/html/OS/BPA/

Try to runnit from the cli if not.

L0 Member

I was able to get this running. I did the follwing:


expedition@Expedition:~$ sudo apt-get update

And I looked in the directory previously mentioned and found a zip:

expedition@Expedition:~$ cd /var/www/html/OS/BPA/
expedition@Expedition:/var/www/html/OS/BPA$ ls

So I unzipped it:

expedition@Expedition:/var/www/html/OS/BPA$ sudo unzip 

Then cd to the directory and see the files:

expedition@Expedition:/var/www/html/OS/BPA$ cd best_practice_assessment_ngfw_pano-master/
expedition@Expedition:/var/www/html/OS/BPA/best_practice_assessment_ngfw_pano-master$ ls
best_practice_assessment_ngfw_pano  Dockerfile.test  pytest.ini  requirements.txt  test-requirements.txt                            VERSION

I read the README file and followed the "Clone method". Which is to use the pip command to install.  I ran the following commands:



pip install -r requirements.txt
###  a message warned me that I needed to upgrade pip
sudo pip install --upgrade pip
sudo pip install -e .

I went to the web UI and hit refresh and BAM! It worked.


I assumed this feature would be enabled by default, but I installed this in Fusion on my laptop and in the customer's environment after converting it with the VMware converter - both installs had the issue of not displaying BPA results after running the analysis. 


I hope this helps.



Thanks for the guide. Worked for me. 

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!