upgrading from PA-3020 to PA-3220 HA2 error

cancel
Showing results for 
Search instead for 
Did you mean: 

upgrading from PA-3020 to PA-3220 HA2 error

L1 Bithead

Hi

Trying to upgrade from a PA 3020 to a PA 3220 but when we import the running state from the PA 3020 and then click commit we get this error. Validation Error:
deviceconfig -> high-availability -> interface -> ha2 -> link-speed unexpected here
deviceconfig -> high-availability -> interface -> ha2 is invalid

 

I have edited the XML so that there is no reference to HA2 but it still gives the error. On the new 3220's there is a HSCI port for HA2 that does not need the link-speed setting. 

 

Has anyone run into this and what was your solution?

8 REPLIES 8

Cyber Elite
Cyber Elite

I would agree that you are doing the only thing possible, which is to modify the xml code.

If you are getting a validation error after removing references to HA2, then I would try to see how the 3220 references when you use the HSCI and see what syntax you can use.

 

Only other option (if it was me) was to remove ALL references to HA config completely from the 3000 series xml file, validate, and then re-create the HA config on the 3220, after importing (and validating)

 

Good luck, I think you are in the right place and steps seem correct. 

Help the community: Like helpful comments and mark solutions

Modified the running-config XML file and still received the same error message. Found a template XML in the system state files and it also had references to the interfaces. Modified both files and config was properly committed.

I was doing the same upgrade from a 5020 to a 5250 and was receiving the same error about HA2 -

deviceconfig -> high-availability -> interface -> ha2 -> link-speed unexpected here

deviceconfig -> high-availability -> interface -> ha2 is invalid

 

Since my commit was failing, I went into the CLI and ran - show deviceconfig high-availability interface ha2

I could see the link-speed and link-duplex were both auto.

So I just ran the delete command on HA2 to clear out those settings - delete deviceconfig high-availability interface ha2

 

Then was able to add my config back to HA2 and commit successfully.

Hi Samtec-Matt

 

That was easier then going through the XML files and finding the references. I have two more to do yet and will try this instead.

FYI, delete the ha2 via CLI worked for me.

Updating Device State XML's worked for me. Had the same issue going from 5060 to 5260. CLI didn't work and neither did editing the running-config.xml. Due to Panorama templates in place I had to edit the xml's in the template folder too within the device state zip. 

Thanks that did worked for us.

SD-WAN | Cloud Networking | PCNSE | ICSI CNSS | MCNA | | CCNP | CCSA | SPSP | SPSX | F5-101 | CCIE-SEC-Attempted

worked  !!!! 

 

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!