SSL decryption inconsistency

Reply
Highlighted
L2 Linker

SSL decryption inconsistency

Hi,

 

I have enabled decryption on a small group for testing purposes. I have a simpel 2 rule setup, first exluding financial, health and custom white listed and then decrypt everything else.

 

I have a hard time finding out why the same site in the same browser on different pc's behave differently. For example my colleague got ERR_SSL_PROTOCOL_ERROR on https://reddit.com with chrome while at the same time it was ok on my pc, also with chrome. How do I examine those kinds of errors?

 

Further, I lack more how to's and best practises in general regarding ssl decryption. Like how you should maintain the firewalls list of trusted CA's, both changed and revoked CA's. 

 

Any tip you have about seting it up and adminstering ssl decryption is appreciated!

 

Regards

Magnus

Highlighted
L5 Sessionator

Re: SSL decryption inconsistency

what is the PA-OS of  the firewall?

Highlighted
L5 Sessionator

Re: SSL decryption inconsistency

Highlighted
L2 Linker

Re: SSL decryption inconsistency

We run 6.0.10 on 3020 in passive/active HA.

 

There are some helpful stuff in that link but most of it for the setup.

 

Could there be mismatches between certs in windows (7/8) and in palo?

Highlighted
L2 Linker

Re: SSL decryption inconsistency

A couple of things from my own experience with testing decryption (6.0.14 on the GWs) -

 

- After changing the decryption policy it can need to rebuild the certificate cache as sites are accessed, so you are best to leave off testing  for 5 mins or so otherwise you can get odd results

 

- Browser cache can also produce different results (yes - I know SSL results shouldnt be cached, just passing on what I found) so if you get odd results be sure to CTL + F5

 

Might help ?

 

Nick.

Highlighted
L2 Linker

Re: SSL decryption inconsistency

The policy has been running for a few months so I guess caching isn't a problem.

Highlighted
L2 Linker

Re: SSL decryption inconsistency

No one has any idea?

Highlighted
Cyber Elite

Re: SSL decryption inconsistency

Do all the clients have the trusted cert that was uploaded into the PAN? I know we perform this and chose and internal cert since it was already deployed to all of our clients. We then had to export a cert to the PAN that allowed the PAN to be a subordinate to the CA so it could genereate certs on the fly for the ssl decrypt.

Highlighted
L3 Networker

Re: SSL decryption inconsistency

You may want to look at:

 

https://live.paloaltonetworks.com/t5/Discussions/PAN-OS-7-0-2-SSL-Decryption-certficate-untrust-issu...

 

I know this is for 7.0.2 but the question is if this potential bug may have found it's way into newer versions of 6.0.x and 6.1.x.

 

You could try upgrading to 6.0.11 and see if it helps as well.

Highlighted
Cyber Elite

Re: SSL decryption inconsistency

Sounds like a case with support maybe in order...

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!