Panorama 4.1.8 LDAP Failure

Showing results for 
Show  only  | Search instead for 
Did you mean: 

Panorama 4.1.8 LDAP Failure

Not applicable

Having upgraded our Panorama from 4.1.7 to 4.1.8 - we can no longer use the LDAP user authentication.

The user constantly gets "invalid username or password" (same message on the Panorama) - yet this worked without any problems with 4.1.7

On Panorama - one can see that in the LDAP profile - the Base option is never getting populated (dropdown option is only "none" rather than domain name).

Is this a new "feature" ?




Downgraded to 4.1.7h2, but the same issue popped up again.

Wohaa. Thanks for that Chris. I was looking at upgrading not).

Small warning for people: The 4.1.8 also seems to fail VPN client connection using internal certificates. This might be related to the LDAP issue - not sure thou.



Pretty sure The VPN certificate issue is not a bug - there was a warning/release-note issued, i got an email, that mentioned the certificate must match the name of the URL, and some extra validations that the new versions of client or gateway will do, so if your cert is not created correctly it will probably cause an issue.

I am very curios, I still havent upgraded, but with the man-in-the-middle vulnerability noted a few days ago, i will want to upgrade sooner than later...  how many out there are using 4.1.8 with ldap auth successfully? in other words, are the issues common for everyone or is it just a few that have issues, meaning the solutions in this thread took care of it for most?


btw, here is the content of that email:

Announcement: GlobalProtect 1.1.7 Release Notes Announcement

created by panagent in Palo Alto Networks Live - View the announcement

GlobalProtect 1.1.7 implements enhanced checks for CA Server Certificates chain-of-trust. This change will cause some existing configurations to become invalid and may result in remote users receiving an error when connecting to the portal, or will not be able to connect if the certificate issue is present on the gateway. Before deploying the GlobalProtect Agent 1.1.7 to users, ensure that the Portal and all Gateway server certificates are valid and that the certificate Common Name (CN) fields match the FQDN or IP address of the portal and/or gateway that uses the certificate.

The SSL certificate that you use for the GlobalProtect portal/gateway should have a Common Name (CN) that matches what you configured in the portal settings. For example, if your certificate has the CN of, ensure that your portal configuration lists the gateway as and does not use an IP address and vice versa, otherwise when the GlobalProtect Agent tries to connect it will generate an error specifying that the certificate CN does not match.

Additionally, when the certificate is created, the Subject Alternative Name (SAN) must be exactly the same as the certificate's CN.  If the certificate uses the CN of the DNS name, ensure that the SAN also uses the DNS name and not the IP address. A mismatch will cause the GlobalProtect Agent to recognize that the SAN is not the same as the CN and will also produce the certificate error.

If your certificates are generated by a public certificate authority, then this will be done correctly and you should not have any issues.

Refer to the following tech note for details on configuring server certificates

  Announcement expires on November 25, 2012

Sorry to disappoint you - but the above issue is related to the GlobalProtect agent - not the firmware version on the firewall.

You can experience the problem they mention on any firmware level if you use GP 1.1.7

We saw the authentication problem on a PA with 4.1.8 (and GP 1.1.7). After downgrading to 4.1.7 (still GP 1.1.7) our VPN client certificate authentication worked again.



Not applicable

We have been on 4.1.8 for a few weeks now and had to remove the domain entry from the Kerberos profile to correct the authentication issue when logging into the console. We use Kerberos for our PA administrator accounts.

Did not have to remove this from the LDAP profile, the LDAP profile still has the domain name but not the FQDN. We do not use Panaorama however.

We are having other issues with Group Mappings but this has not been verified as of yet as a firmware 4.1.8 issue, currently working with Tech Support to resolve. The issue is that the PA will randomly drop the group mappings for the user so then none of the rules will match to a user group and they will get our default block policy. As a temporary fix we have to clear user-cache and user-group-cache then restart user-id.

What is the command line to restart User-ID ?

check pid first

admin@oliver(active)> show system resources | match userid

2312       20   0  170m  57m  37m S    0  2.3   3:38.91 useridd

admin@oliver(active)> debug software restart user-id

check pid once more after restart to confirm pid change.

We have investigated the changes in version 4.1.8. and can share our findings:

a) Administrator login now REQUIRES the domain field to be EMPTY

b) User identification generally REQUIRES the domain field to be SET

Until version 4.1.6. wit domain field set everything worked as expected, with 4.1.8. you need to create LDAP/Kerberos settings twice, one entry WITH and one W/O domain name. In addition Authentication sequence must be configured twice as well. Then for Admin accounts you select the Auth Profile with empty domains and for User identification (and possibly other purposes) you select the groups with domain fields set. Not nice but it works.

  • 22 replies
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!