URL Filtering Issue
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

The Enhanced LIVEcommunity Experience is finally here! Learn all about it.

URL Filtering Issue

L4 Transporter

Hi,

 

Without URL Filtering in the Security Profile of the policy, we can access vimeo.com but with URL filtering profile, getting error message below in IE, Chrome and also on the phone. No proxy used, no SSL decryption. This is happening to the category 'continue' and https.

Streaming-media is in Continue Categories. Below is a screenshot of the URL filtering monitor log.

 

Need help please! 

Error.pngDetailedLogView.png

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

L7 Applicator

HTTP traffic

SYN (client to server)

SYN ACK (server to client)

ACK (client to server)

HTTP GET (client to server)

Web Page (server to client but at this point Palo intercepts and sends back Continue Response Page instead)

 

HTTPS traffic

SYN (client to server)

SYN ACK (server to client)

ACK (client to server)

Client Hello (client to server)

Server Hello (server to client)

<<HTTP GET in encrypted payload, Palo can't see it unless traffic decrypted>>

 

Maybe following link will help you a bit

https://live.paloaltonetworks.com/t5/Configuration-Articles/How-to-Serve-a-URL-Response-Page-Over-an...

Enterprise Architect @ Cloud Carib www.cloudcarib.com
ACE, PCNSE, PCNSI

View solution in original post

4 REPLIES 4

L7 Applicator

HTTP traffic

SYN (client to server)

SYN ACK (server to client)

ACK (client to server)

HTTP GET (client to server)

Web Page (server to client but at this point Palo intercepts and sends back Continue Response Page instead)

 

HTTPS traffic

SYN (client to server)

SYN ACK (server to client)

ACK (client to server)

Client Hello (client to server)

Server Hello (server to client)

<<HTTP GET in encrypted payload, Palo can't see it unless traffic decrypted>>

 

Maybe following link will help you a bit

https://live.paloaltonetworks.com/t5/Configuration-Articles/How-to-Serve-a-URL-Response-Page-Over-an...

Enterprise Architect @ Cloud Carib www.cloudcarib.com
ACE, PCNSE, PCNSI

View solution in original post

@Farzana I'd also look at the "traffic" logs and make sure you have a the column "session end reason" that was I think added in PAN-OS 7.0.X.

 

These were just fields I was able to quickly parse out of my enviornment.  It's possible you might find a reason for your 'continue' issue look at the end reason:

 

NOT ( session_end_reason eq policy-deny ) and NOT ( session_end_reason eq 'n/a' ) and NOT ( session_end_reason eq tcp-rst-from-client ) and NOT ( session_end_reason eq tcp-fin ) and NOT ( session_end_reason eq tcp-rst-from-server ) and NOT ( session_end_reason eq aged-out ) and NOT ( session_end_reason eq tcp-reuse ) and NOT ( session_end_reason eq threat ) and ( session_end_reason eq unknown ) and ( session_end_reason eq decrypt-cert-validation ) and ( session_end_reason eq decrypt-error )

L0 Member

Are you on PAN-OS 8.0+? Any reason for the block-continue action in the first line of your logs? We saw a similar issue after moving to 8.0.2 where URLs that were properly categorized were still getting the 'unknown' block-continue treatment. We remedied this by creating a new Profile Setting where the 'unknown' category is set to allow. Will be opening a TAC this week, but this was slowing down mail flow and we saw an instant remediation on creating the new profile. 

Thank you for the suggestions. Issue got resolved by applying decryption on forward proxy.

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!