Global Protect Satellite reconnect via API

Not applicable

Global Protect Satellite reconnect via API


Running PANOS 6.0.2

I'm trying to use the XML API to reconnect a Global Protect Satellite to the gateway but getting:

<response status="error" code="400">
<result>
<msg>Unsupported command.</msg>
</result>
</response>

My API call is:


https://192.168.19.10/api/?type=op&cmd=<test><global-protect-satellite><gateway-reconnect><satellite...


To verify the GP satellite info I ran the following API call:

https://192.168.19.10/api/?type=op&cmd=<show><global-protect-satellite><satellite><name>GPTunnel</na...

The results returned are:

<response status="success">
<result>
<entry>
<satellite>GPTunnel</satellite>
<portal-address>w.x.y.z</portal-address>
<reason>connection failed</reason>
<status-time>1400171499</status-time>
<current-failed-reason>connection failed</current-failed-reason>
<auth-needed>no</auth-needed>
<encap-interface>ethernet1/1</encap-interface>
<ip>a.a.a.a</ip>
<tunnel-interface>tunnel.999</tunnel-interface>
<publish-routes>
<member>b.b.b.b/24</member>
<member>c.c.c.c/24</member>
</publish-routes>
<publish-conn-routes>no</publish-conn-routes>
<cert-profile>certRoot</cert-profile>
<local-cert>ClientCert</local-cert>
</entry>
</result>
</response>

So... I think I'm missing something with the test operational command, any ideas?

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!