Broken email notifications formatting in version 11.0.1

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Announcements
Please sign in to see details of an important advisory in our Customer Advisories area.
Palo Alto Networks Approved
Palo Alto Networks Approved
Community Expert Verified
Community Expert Verified

Broken email notifications formatting in version 11.0.1

L3 Networker

Hi all

 

I noticed that email notifications in ver 11.0.1 are kind of broken from the formatting point if view they just look like a blob of text, instead of a decent formatted email in ver 10.2.4 

 

is there a way to fix it?

 

Thank you

 

broken_email_notifications.png

2 accepted solutions

Accepted Solutions

Cyber Elite
Cyber Elite

@nevolex,

As @SCantwell_IM mentioned I would bring this up with your SE. I can tell you that mine was already aware of the issue and said that it'll likely be fixed in the next release and that some clients had already opened a TAC case about it. You can either wait for it to be fixed or customize the email format so that it's formatted properly, as that will resolve the issue. 

View solution in original post

L3 Networker

PAN-OS 11.0.3 got released and the Bug is on the "fixed" list.

https://docs.paloaltonetworks.com/pan-os/11-0/pan-os-release-notes/pan-os-11-0-3-known-and-addressed...
I've updated a Panorama already and waiting for the first e-mail to make it's way to my inbox.
Yeah got my Panorama E-Mails in and all is fine again.

Palo also released 10.2.7 and the Bug made it to the fixed list.

https://docs.paloaltonetworks.com/pan-os/10-2/pan-os-release-notes/pan-os-10-2-7-known-and-addressed...

Cheers
Alex

There's no home like 127.0.0.1

View solution in original post

26 REPLIES 26

Cyber Elite
Cyber Elite

Hello there, based on the </br> that shows up in the 11.0.1, I am guessing that there is a programming defect/ anomaly in how the logs are transmitted.  You "may" be able to try and create a custom email format vs using the default format that comes from the devices.


After that, a bug/ Feature Request ticket should be submitted to your local PANW SE (not the TAC) for getting this in front of engineering to fix this.  This is my recommendation.

Help the community: Like helpful comments and mark solutions

Cyber Elite
Cyber Elite

@nevolex,

As @SCantwell_IM mentioned I would bring this up with your SE. I can tell you that mine was already aware of the issue and said that it'll likely be fixed in the next release and that some clients had already opened a TAC case about it. You can either wait for it to be fixed or customize the email format so that it's formatted properly, as that will resolve the issue. 

L2 Linker

Same problem going from 10.1.8 to 10.1.10

L0 Member

Ditto, 10.1.8 to 10.1.10

L0 Member

Same problem going from 10.1.8 to 10.1.10. Are there workarounds or do we have to wait for a new fix?

L2 Linker

@BPry @SCantwell_IM , Hello guys! I see this issue (thread) was way back in April, do you guys by chance have an update on this?
Looking at the release notes for 11.0.x, it seems that it is not yet identified as a known issue nor being addressed.

L1 Bithead

This broke when upgrading from 10.2.4(h4) to 10.2.5 as well. Sad this is nearly 4 months old and still being broken with brand new PAN releases.

L0 Member

Broken again in version 10.1.10-h1 and 10.1.10-h2, its a recurrent issue. HTML formatting should be avoided, its preferable some plain text or other customizable options.

How can you customize the email format to make it formatted properly? I tried making a custom format, but it replaces backslash n (new line) with the html br forward slash tags. I tried adding an opening html tag, but this didn't work either. My SE has failed to reply to my inquiry.

L3 Networker

I can confirm. we upgraded from 10.2.4 > 10.2.5 and it is broken now. It was working fine in 10.2.4

Seriously and what is the BugID for this?
I cannot find it under Open/Known issues for 10.2.5

UPDATE: searching within 11.0.1 Know Issues, one can find the BugID

PAN-221126
Email server profiles (
Device
Server Profiles
Email
and
Panorama
Server Profiles
Email
) to forward logs as email notifications are not forwarded in a readable format.
Workaround:
Use a
Custom Log Format
to forward logs as email notifications in a readable format.

I do use a custom LogFormat, but all line breaks still won't work, which makes the email not readable

 

When will Palo Alto finally give us a useable bug search tool, the current possibilities are just utter useless.

Also having BugIDs not published > Manual GP Gateway selection for Gateways behind NAT devices does not work. Was not published because its a duplicate of "Certificate auth not working when GP Gateway behind NAT device". Guys please why do we even bother going through release notes at all anymore?

 

Sorry just had to let it out. It's the second time within weeks that stuff like that happens.
So much to 10.2.5 being the holy grail of 10.2.x releases that finally fixes many issues we are facing.

There's no home like 127.0.0.1

Cyber Elite
Cyber Elite

@AlexNC,

So the bug IDs are just specific Jira issues that are entered, same for feature requests and the like. That's why you'll always here about having your SE "vote" for a FR, if you've ever used Jira that starts to make more sense. To your point directly, PAN has taken this approach that Jira is an internal resource and they don't want to grant customers access to said resource. This makes sense from a security aspect since everything is kind of in one instance.

What doesn't make any sense is that it's not hard to drive other applications with information within Jira. We do that heavily internally and I wouldn't say our developers are anywhere near top notch. PAN could easily expose FRs and bug IDs if they actually wanted to, they seemingly don't wish to spend the time required to build a portal.

 

Long winded way of saying I don't have an answer for you, because I've never gotten an actual answer that was satisfactory either. Exposing FRs and bug IDs so that the community at large can add votes to FRs without going through their SE, know what is already out there, and have access to relevant bug information (like the vast majority of other vendors) would be a big positive. 

I totally agree with you and also other vendors suffer the same issues with some bugs are beeing internal and some are public.

But the sheer amount of simple bugs (we're not talking high severity bugs that leave you with your pants down) are not listed. Also if there are simple..... I am talking about DEAD simple workarounds to fix an issue/bug.

I've seen my fare share of Jiira and that there is to much information put into it, that would expose the customer that actually opened the first case for a given issue 🙂
But com'on add some fields for a sanitized version. Start creating all new TAC Cases/Jiira Issues with the new mask.
higher some fresh from from school coders that automate the sanitizing of all existing Jira entries, then have a few senior TAC Engineers that know the product to review quicky and make sure no confidential information is leaked/visible.

Even if the cleanup/split is not perferct (just look at some other Vendor BugIDs with their descryption/symptoms/workaround/solution part.

BTW: Just a couple of weeks ago. I was able to take a BugID e.g PAN-221126 and add it to the general "search" bar on the top right. This way I could find all the PAN-OS Versions that the Bug is listed. This does not work anymore 😞

Screenshot 2023-09-05 at 14.53.28.png

There's no home like 127.0.0.1

I found a workaround to the BugID Search within the PAN-OS Release Notes.
If you search for the BugID PAN-221126 like this, it will not show any results see below.

Screenshot 2023-09-05 at 14.56.21.png

 

But if you search for PAN-221126/ > yes adding a / at the end, I do get some results back (it's more then what I want and searched for, but the first hits do show the correct releases).

Screenshot 2023-09-05 at 14.56.57.png

There's no home like 127.0.0.1

I did end up opening a TAC case. They had (as of last week) no planned fixed release for 10.2, but did state it should be fixed in 10.1.11 and 11.0.3 if you are on those trains (I'm on 10.2, unfortunately).

  • 2 accepted solutions
  • 9120 Views
  • 26 replies
  • 3 Likes
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!