Question about PAN::XAPI module

Reply
Not applicable

Question about PAN::XAPI module

Hello,

I was trying to use the PAN::XAPI module provided in the PAN-perl-20120107.tar.gz package and I ran into an issue. When I try to use PAN::XAPI to make request using the API key specified in my .panrc I recieve "User not authorized to perform this operation" error messages.

When I try accessing the API via other methods (i.e. manual entry into a web browser and scripts that don't use PAN::XAPI) it works fine. Judging from output that I was able to see for a debug, it looks like the PAN::XAPI module is actually URL encoding the key, which causes issues.

Does anyone have any recommendations?

L4 Transporter

Re: Question about PAN::XAPI module

Solomon - this is known issue in Panperl. Yeah you are right that pan perl is encoding already encoded key. We are planning to fix this in the next release.

For now please generate a key that works and provide it in .panrc file and continue using it.

Thanks,

krishna

Krishna Somu

Technical Marketing Engineer, Palo Alto Networks

408 753 3896 (office)

650 823 7086 (mobile)

L3 Networker

Re: Question about PAN::XAPI module

I had the same issue and the trick is to keep generating the API key untill it consists letters and numbers ONLY

Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the Live Community as a whole!

The Live Community thanks you for your participation!