API in python works but in browser fails

Showing results for 
Show  only  | Search instead for 
Did you mean: 

API in python works but in browser fails

L4 Transporter

Trying the API in browser. Clicking either submit or the URL give me error "show rule hit count op-command failed'

Tried on 5250 multi-vsys and 220, both on 8.1.8-h5












I managed to run the code and used on my firewall and was successful. But direct browsing fails.




This uses



<show><rule-hit-count><vsys><vsys-name><entry name='vsys1'><rule-base><entry name='security'><rules><all></all></rules></entry></rule-base></entry></vsys-name></vsys></rule-hit-count></show>"





L5 Sessionator

The reason it's failing is because the GUI API browser is already at the following XML location (per your first screenshot):  show > rule-hit-count > vsys > vsys-name


The API browser kinda fails when you need to give multiple params at a specific depth...  I don't know if it'd work, but you could try going back to the vsys location, then pasting the entire vsys-name block from opening to close and see if that works..?

@gfreeman I browsed API till vsys-name and there is nothing below it. Also i tried going up it still failed.

Then i copied the text above and it showed results although not human readable





  • 2 replies
  • 71 Subscriptions
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!