can't login to web console

Showing results for 
Show  only  | Search instead for 
Did you mean: 
Please sign in to see details of an important advisory in our Customer Advisories area.

can't login to web console

L2 Linker

I have just instaled MM on Ubunto 16.04. Using these instructions:

Howto on Ubuntu 16.04

$ sudo apt-get update
$ sudo apt-get upgrade
$ sudo apt-get install -y gcc git python-minimal python2.7-dev libffi-dev libssl-dev make
$ wget
$ sudo -H python
$ sudo -H pip install ansible
$ git clone
$ cd minemeld-ansible
$ ansible-playbook -K -i, local.yml
$ usermod -a -G minemeld <your user> # add your user to minemeld group, useful for development


It appears to be running and the web interface comes up. 


When I try to login using ether admin:minemend or my user:password the login times out. "error checking credintals : Timeout"


I tried to follow these instructions to fix this:



sudo service minemeld stop
sudo -H -u minemeld /opt/minemeld/engine/current/bin/pip install pip==9.0.3
sudo service minemeld start


This didn't fix the problem ether. 


Any ideas on how to fix this?


L2 Linker

So no replys yet, but I gathered this from the MineMeld-web.log


[2019-05-06 08:13:21 +0000] [16654] [INFO] Starting gunicorn 19.5.0
[2019-05-06 08:13:21 +0000] [16654] [ERROR] Connection in use: ('', 5000)
[2019-05-06 08:13:21 +0000] [16654] [ERROR] Retrying in 1 second.
[2019-05-06 08:13:22 +0000] [16654] [ERROR] Connection in use: ('', 5000)
[2019-05-06 08:13:22 +0000] [16654] [ERROR] Retrying in 1 second.
[2019-05-06 08:13:23 +0000] [16654] [ERROR] Connection in use: ('', 5000)
[2019-05-06 08:13:23 +0000] [16654] [ERROR] Retrying in 1 second.
[2019-05-06 08:13:24 +0000] [16654] [ERROR] Connection in use: ('', 5000)
[2019-05-06 08:13:24 +0000] [16654] [ERROR] Retrying in 1 second.
[2019-05-06 08:13:25 +0000] [16654] [ERROR] Connection in use: ('', 5000)
[2019-05-06 08:13:25 +0000] [16654] [ERROR] Retrying in 1 second.
[2019-05-06 08:13:26 +0000] [16654] [ERROR] Can't connect to ('', 5000)
[2019-05-06 08:13:27 +0000] [16658] [INFO] Starting gunicorn 19.5.0
[2019-05-06 08:13:27 +0000] [16658] [ERROR] Connection in use: ('', 5000)
[2019-05-06 08:13:27 +0000] [16658] [ERROR] Retrying in 1 second.
[2019-05-06 08:13:28 +0000] [16658] [ERROR] Connection in use: ('', 5000)
[2019-05-06 08:13:28 +0000] [16658] [ERROR] Retrying in 1 second.


Does this help anyone?

L1 Bithead

Im getting the exact same thing. I was able to log in yesturday but as it stands now I have no way of logging in via the Web console

Keep getting errors "ERROR CHECKING CREDENTIALS: Timeout"

Resarted the Ubuntu server multiple times, restarted minemeld service.


sudo -u minemeld /opt/minemeld/engine/current/bin/supervisorctl -c /opt/minemeld/local/supervisor/config/supervisord.conf status

and all are running

issued a restart via sudo -u minemeld /opt/minemeld/engine/current/bin/supervisorctl -c /opt/minemeld/local/supervisor/config/supervisord.conf resart all

Verified all services running

Checked rabbitmq-server, redis-server and collectd and all are running.


Checker resource usage via TOP and all is fine and checked disk storrage, all is well to


Still cannot log into the web interface

Senior Security Engineer

Glad I'm not alone.

Same issue here. Im two months late and I still dont see this being resolved. 


have anyone a fix for our problem?

i have the same Login Error after a new installations

L0 Member

Hi there,


I had the same problem, after deploying it on debian10 buster (stable).


What I did was:


Install gunicorn and some deps:

pip install gunicorn
pip install -r /opt/minemeld/engine/core/requirements.txt

Then I stopped minemeld web process:

sudo -u minemeld /opt/minemeld/engine/current/bin/supervisorctl -c /opt/minemeld/supervisor/config/supervisord.conf stop minemeld-web

And I checked supervisor config in order to launch command with all variables set :

cat /opt/minemeld/supervisor/config/conf.d/minemeld-web.conf

command=/opt/minemeld/engine/current/bin/gunicorn -w 1 -b --worker-connections 500 --access-logfile - --error-logfile - -k gevent minemeld.flask.main:app


So then I exported vars :

export MM_CONFIG="/opt/minemeld/local/config/" ; export PATH="/opt/minemeld/engine/current/bin":$PATH ; export HOME="/opt/minemeld/local/data" ; export MINEMELD_PROTOTYPE_PATH="/opt/minemeld/local/prototypes:/opt/minemeld/prototypes/current"

And ran minemeld web via commandline:

cd /opt/minemeld/engine/core
/opt/minemeld/engine/current/bin/python2.7 /opt/minemeld/engine/current/bin/gunicorn -w 1 -b --worker-connections 500 --access-logfile - --error-logfile - -k gevent minemeld.flask.main:app

It threw errors about packages missing so I installed them:

pip install flask
pip install passlib.apache
pip install passlib

So finally I relaunched again and it worked. 

I realized I was doing it with root user so I stopped it and ran as minemeld to check there were not permission problems:

sudo -u minemeld /opt/minemeld/engine/current/bin/python2.7 /opt/minemeld/engine/current/bin/gunicorn -w 1 -b --worker-connections 500 --access-logfile - --error-logfile - -k gevent minemeld.flask.main:app

It started correctly and I was able to login into web console. So I canceled command and started from supervisor:

sudo -u minemeld /opt/minemeld/engine/current/bin/supervisorctl -c /opt/minemeld/supervisor/config/supervisord.conf start minemeld-web

Now is working, but it took about 4 hours of debugging due to lack of error logs on minemeld log folder.

I hope this helps any other having same problem.

A process is using port 5000. Find the process and run the kill command.

L0 Member

So I did a fresh VM install from CentOS 7 (minimal install) using the instructions here:


which are basically OPs steps and I have this problem too...I have no idea how to troubleshoot this...

  • 8 replies
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!