Custom report emails blank??

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Custom report emails blank??

L4 Transporter

I have 4 custom reports that if I 'run now' they display relevant information.  But once I put them in a group and scheduled them to email/run everynight they come through blank with the message 'There is no PA-report-01 report on Sunday, Mar 18.'    Under 'Report Groups' I had them selected under 'Custom Report' but changed to them 'Log view'  but not sure if that was the problem.  Can someone help me out?   

 

 

 

 

 
 
9 REPLIES 9

Community Team Member

Hi @drewdown,

 

With regards to the API question ... check out the following blog I wrote on XML API not too long ago.  It has similar behaviour with logs.  You'll probably need to perform an additional api call with the job-ID embedded (as shown in the blog).

 

https://live.paloaltonetworks.com/t5/Community-Blog/The-Power-of-XML-API/ba-p/202789

 

Hope this helps !

-Kiwi.

 

 

LIVEcommunity team member, CISSP
Cheers,
Kiwi
Please help out other users and “Accept as Solution” if a post helps solve your problem !

Read more about how and why to accept solutions.

Thanks kiwi!  Once I added the key I was able to pull the report with the right job-id.  Now if someone can just help me get the blank reports fixed via email.  

Community Team Member

Hi @drewdown,

 

As for the email issue ... I'm pretty sure it's caused by the 'Log View' option you selected.

 

I recall from way back that this setting caused issues with table formatting and whatnot when sending out email reports.

Basically, don't use 'Log View' for emailed reports and set it to 'Custom Report'.

 

Cheers !

-Kiwi.

LIVEcommunity team member, CISSP
Cheers,
Kiwi
Please help out other users and “Accept as Solution” if a post helps solve your problem !

Read more about how and why to accept solutions.

@kiwi

 

It was 'Custom Report' from when I first set it up and they were blank.   I just changed them to 'Log View' today but they won't run until later tonight.  

Community Team Member

Hi @drewdown,

 

I believe that depending on the cycle you selected, custom reports you'll have to wait for a full cycle to get your first report... and everything created before the end of the first cycle will be empty.

 

You might want to check with TAC just to be sure about this though.

 

Cheers !

-Kiwi.

 

LIVEcommunity team member, CISSP
Cheers,
Kiwi
Please help out other users and “Accept as Solution” if a post helps solve your problem !

Read more about how and why to accept solutions.

@kiwi

 

cycle?  Been running/email these for a week with no change.  Opened a TAC case.

Community Team Member

@drewdown,

 

Yes, meaning that if you configured a 7day report, you'll have to wait 7days before you'll get any info in your emailed custom report.

 

Good luck !

-Kiwi.

LIVEcommunity team member, CISSP
Cheers,
Kiwi
Please help out other users and “Accept as Solution” if a post helps solve your problem !

Read more about how and why to accept solutions.

L0 Member

@drewdown Did you ever solve this problem?  I have been dealing with this same issue for a few weeks and TAC has been unhelpful and I have not been able to solve it myself. 

Its been so long man I can't say if I ever did.  I did go look at the case in PANs support portal but I don't see a resolution.  Just a bunch of talk about upgrading to the latest OS which at the time was like 8.0.8.  

  • 5882 Views
  • 9 replies
  • 0 Likes
  • 101 Subscriptions
Like what you see?

Show your appreciation!

Click Like if a post is helpful to you or if you just want to show your support.

Click Accept as Solution to acknowledge that the answer to your question has been provided.

The button appears next to the replies on topics you’ve started. The member who gave the solution and all future visitors to this topic will appreciate it!

These simple actions take just seconds of your time, but go a long way in showing appreciation for community members and the LIVEcommunity as a whole!

The LIVEcommunity thanks you for your participation!