Cortex XDR Discussions
Cortex XDR allows you to rapidly detect and respond to threats across your networks, endpoints, and clouds. It assists SOC analysts by allowing them to view ALL the alerts from all PANW products in one place, telling the full story of what actually happened in seconds and allows seamless response.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Cortex XDR Discussions
Cortex XDR allows you to rapidly detect and respond to threats across your networks, endpoints, and clouds. It assists SOC analysts by allowing them to view ALL the alerts from all PANW products in one place, telling the full story of what actually happened in seconds and allows seamless response.
About Cortex XDR Discussions

Cortex XDR allows you to rapidly detect and respond to threats across your networks, endpoints, and clouds. It assists SOC analysts by allowing them to view ALL the alerts from all PANW products in one place, telling the full story of what actually happened in seconds and allows seamless response.

Please note: All postings in LIVEcommunity are visible to other users; please keep your network secure by refraining from posting live IP address’s or domain names here. Contact your Customer Success team for network-specific questions.

Discussions

Welcome to the Cortex XDR Discussions!

To make this forum valuable and enjoyable for everyone, please review the following guidelines before participating: Rules and Best Practices Be Respectful: Treat fellow community members with professionalism and courtesy. Constructive discussions are encouraged; disrespectful or inflammatory comments are not. Stay On-Topic: This board is d...

JayGolf by Community Team Member
  • 4392 Views
  • 0 replies
  • 3 Likes

XDR AGENT ALL DEVICES

Hi everyone, Does anyone know of or have an automation to periodically check if all devices in the company have the Cortex XDR Agent installed I currently use Mapper, but my network is large, with over 35k devices (including computers, printers, access points, and other equipment). How do you manage XDR coverage in your infrastructure? Do you ...

tlmarques by L4 Transporter
  • 2006 Views
  • 2 replies
  • 0 Likes

Cortex XDR Generate Alert when Device is Online

There's many situations where it would be convenient to receive a notification when a device is online. We often run into this when a device is isolated and we are unable to contact a user. Since there is no native ability to trigger an alert or notification I had an idea to run a script on an endpoint that will create a file and then create ...

tc0222 by L0 Member
  • 2759 Views
  • 3 replies
  • 0 Likes

Broker VM

Hi, I have downloaded Broker VM OVA file and installed it on my VMvare. I just wonder about with the following issues. As you know Broker has two IP one for public and one for private. In this part, if i go static, will I be configuring internal or public IP? I mean should I just take one static IP from my internal network for example, 192.16...

JahidAliyev_0-1731635966017.png

General Cortex XQL questions

Hello, I have been unable to confirm the following information in the online guidance I have been looking through. How far back can we run an "All Actions" query in XQL? For example, can we search for file hashes going back 3 months or longer?Also, what is the difference between running an "All Actions" query vs using the XQL Search option? W...

BIOC that will close web browser while opening certain websites

I want to create a BIOC rule that will close web browser (ex. chrome) when I open certain websites (ex. facebook.com and instagram.com). I'm using Network BIOC and I managed to create BIOC rule that applies only to one website (remote host) but I don't see the option where I can add multiple websites (remote hosts). Can you help me with that? Ma...

Resolved! Correlation rules create incident

Hey dear sec community! is there a way to setup an correlation rule, which can block and not only detect?I couldn't find a way. I tried the XQL queries from the libary. https://docs.paloaltonetworks.com/cortex/cortex-xdr/cortex-xdr-pro-admin/investigation-and-response/cortex-xdr-indicators/working-with-correlation-rules/create-a-correlation-rul...

Cyber1985 by L3 Networker
  • 7256 Views
  • 7 replies
  • 0 Likes

Resolved! Device connection alert

Hi everyone, I'm kind of new to the Palo Alto Networks ecosystem, and it seems that in Cortex XDR, you can't create your own "alerts", only queries/scheduled queries. My goal here is to find a way to be alerted/informed when a specific device is connected to the internet. For more context, it would more specifically used for stolen laptops, so t...

G.Louhou by L1 Bithead
  • 1963 Views
  • 2 replies
  • 0 Likes

Microsoft 365 email collector

Hi Everyone Regarding the new email collector which ingests email logs and data from Microsoft 365: Ingest logs and data from Microsoft 365 • Cortex XDR Documentation • Reader • Palo Alto Networks documentation portal Has anybody figured out a way to properly test it? Thanks & Best Regards

Rocky-25 by L2 Linker
  • 1574 Views
  • 2 replies
  • 0 Likes

Performance Optimization Strategies

Hello, I have a system running workloads that is sensitive to CPU usage. The primary users have raised an issue that our currently applied XDR profile is causing detrimental delays in job processing. I confirmed this by disabling the agent to observe baseline activity. The current profile/policy has Exploit and Malware prevention set to "monit...

Blocking connections to malicious IP address?

Hello, I have a question. I have Cortex XDR agents installed on my endpoints. I just recently also installed Forti Analyzer and it detected some potential malicious IP addresses that my endpoints have connections to. I wonder why Cortex XDR cannot detect and block connections to these malicious IP addresses. Some of these malicious IPs are 13...

Resolved! Use 2 datasets in the same XQL query

Hello, I would like to be able to use the dataset “xdr_data & endpoint” in the same query. Here's my query : dataset = xdr_data| filter event_type = ENUM.FILE and event_sub_type = ENUM.FILE_OPEN | alter Drive_Type = json_extract(to_json_string(action_file_device_info),"$.storage_device_drive_type"), Filesystem = json_extract_scalar(to_jso...

Need help with BruteForce XQL query

Hi i am trying to craft a query for bruteforce based on 30min timeframe with threshold of more than 5 failed login attempts. But i am having trouble figuring out how to configure the logs for a 7 Days monitoring. Please kindly help me refine the query, thank you so much for your help. config timeframe = 30M| dataset = xdr_data // Using the...

  • 2611 Posts
  • 98 Subscriptions
Top Solution Authors
Top Liked Authors